Friday, July 21, 2006

Help Installing Workplace Managed Client for Linux

Well, I'm having to install WMC as part of the install process for something I downloaded at Passport... Looks like it was pretty popular

The documentation states that you must be running Mozilla 1.7.12. No problem, even though I was at 1.2.1 I downloaded 1.7.12 and installed it in the /usr/lib/mozilla-1.2.1 directory over the 1.2.1 install. I launch Mozilla and it's 1.7.12. But the WMC install fails with "Can not validate Mozilla version".

Here is the Google search for that. As you can see, the IBM WCS 2.5 release notes state the following. Please note that I did not even have a /etc/gre.conf file on the system. I didn't even have a gre.conf! I created the file and modified the version and path as specified in the WSE release notes. See below:

When installing the Workplace Rich Client on a Linux workstation, the error "Cannot validate Mozilla version" indicates that version 1.4 of Mozilla with GTK2 binding is not installed on the workstation, or it is not installed in the expected location.

The file "/etc/gre.conf" contains information on the Mozilla version and the variable "GRE_PATH" whose value should point to the directory location where the appropriate Mozilla version has been installed. In a default RedHat installation this file contains the following information: (NOTE: The information I tried putting in is beside each line in italics)
[1.4] ([1.7] and also [1.7.12])
GRE_PATH=/usr/lib/mozilla-1.4 (GRE_PATH=/usr/lib/mozilla-1.2.1)
To fix this error do the following:
1. Download Mozilla 1.4 for RedHat from the followin ftp URL "
-suse82.tar.bz2" .
2. Extract the contents of this file to /usr/lib/mozilla-1.4 directory.
3. Create or update "/etc/gre.conf" to have the first two lines as below
4. Reinstall Workplace Managed Client platform.

No comments: